Computations & Graphics, Inc.

FAQs

 

Technical support is available via email to our customers for the first 30 days. Your email is generally replied within 24 hours. Send your questions via email to support@cg-inc.com. You should include the model file with the email so we can diagnose the problems more easily. CGI, in its sole discretion, will determine what constitutes a support incident and reserves the right to refuse support service to anyone.

You are strongly encouraged to read our program documentation first since many of your questions may have answers there already. Our programs are so easy to use that you probably seldom need our technical support. The following are some frequently asked questions.

 
 

Real3D - General

  • Does Real3D use dongle for copy protection? No. We use software key which is emailed to you after purchase.
  • What types of licenses do you have for Real3D? Perpetual and Subscription-based.
  • Can I install Real3D on both a desktop and a laptop? Yes as long as you do not use the software on both computers at the same time.
  • Is Real3D just another structural analysis program? Real3D is a comprehensive structural analysis and design program that is extremely accurate, reliable and user-friendly. It is NOT just another structural analysis program. In particular, it is NOT any of the following: an old program with just a new (poorly designed) Windows user interface; a new program that uses inefficient or unreliable frame or finite elements; a program that uses unreliable or inefficient proprietary "home-made" graphics; a program that is not enjoyable to use; a program that costs you too much.
  • How do you ensure that Real3D produces the correct results? The correctness of results is of utmost importance for a structural or finite element analysis program. This is implemented during various phases of the product development. Design Philosophy: Accuracy and reliability come before any other program features. Implementation: Only the most reliable frame and finite element formulations are used. These formulations are implemented in the most reliable algorithms and programming language. Verification: Three methods are employed in the program verifications. a). Hand calculation. It is the most reliable method and is used whenever possible. b). Comparing with respectable published references such as MACNEAL, R.H., HARDER, R. L.; “A Proposed Standard Set of Problems to Test Finite Element Accuracy”, Finite Elements in Analysis and Design 1 (1985) 3-20, North-Holand. c). Comparing with other reputable finite element software such as ADINA. The verification examples in the program documentation are the typical testing problems. Many more problems were tested in-house.
  • How large a model can Real3D solve? That depends on many factors including your computer hardware. We have used 64-bit Real3D to solve models with over 3 million degrees of freedom on a modern (2013) computer with 16 GB memory.
  • What are the differences between 32-bit and 64-bit versions of Real3D? 1). 32-bit Real3D can run on both 32-bit and 64-bit Windows. It can only use up to 4 GB computer memory.
    2). 64-bit Real3D can only run on 64-bit Windows. It can use computer memory beyond 4 GB and thus can be used to solve very large models.
  • Is Real3D user-friendly? Many engineering software companies claim to have the most user-friendly software. This is certainly easy to say. You have to judge it (including Real3D) for yourself. But try to ask yourself the following questions: Does the software have a simple, clean and consistent Graphical User Interface (GUI)? Does the software use a shaky (unreliable or inefficient proprietary) "home-made" graphics or stable industry-strength graphics? Is it possible to create a simple model without the user's manual? Does the software produce dozens of different files with strange names when you perform an analysis? Does it look even like a normal Windows program? Are you looking forward to using that software again?
  • How do I know if my graphic card supports OpenGL(R) acceleration or not? To see whether your graphic card is OpenGL(R) accelerated or not, go to the program menu Help | About. If you can see "Installable Client Driver" in the about dialog box, then it is. Otherwise, it is not. Virtually all modern computers have hardware accelerated OpenGL(R) graphic cards.
  • I can not run some commands after performing an analysis, why? This is most likely due to the automatic locking of the model. You can uncheck the option "Lock model after an analysis is performed successfully" from Settings | Preferences. Also, some data in spreadsheets cannot be modified if this option is on or if you check the option "Show only selected entities in spreadsheet" in Settings | Data Options.
  • I can not edit data in some spreadsheets This is most likely due to the automatic locking of the model or "show only selected entities in spreadsheet" option is checked. You can uncheck the option "Lock model after an analysis is performed successfully" from Settings | Preferences and/or the option "Show only selected entities in spreadsheet" in Settings | Data Options.
  • Why can't I select elements by mouse while viewing deflected shape of the model? This behavior is by design. To be able to select by mouse, you may set the displacement magnification factor to be 0 from View | Deflection Diagram or simply run View | Restore Model. This behavior does not happen when there are no results.
  • What programming language was used to develop Real3D? Real3D was written in its entirety in standardized C++, a programming language that is used in mission critical projects around the world. No FORTRAN, no Visual Basic, no C, no Java, no C#, no legacy code, period!
  • What are the limitations of the evaluation version of the software? The evaluation version of Real3D 1). can read, create and solve models of any size but cannot save models with more than 16 nodes; 2). may not be used for professional purpose.

Real3D - Modeling

  • What kinds of structures can the program analyze? Real3D provides comprehensive frame and finite elements to analyze any practical structures. Examples are 2D or 3D trusses, 2D or 3D Frames, 2D or 3D plates and shells such as floors, mat foundations, shear walls, curved roof, water tanks, and 3D solid structure. You can mix different types of elements in the model.
  • How big a model can the program handle? The capacity of Real3D depends on the version you are running. Real3D Professional sets no practical limit with regard to the number of nodes, elements etc. For example, the actual limit for the number of nodes is 2^31 - 1 = 2,147,483,647. However, your computer probably will run out of memory long before it reaches this limit. Other versions of Real3D have capacity limitations deliberately imposed.
  • What is the 128-bit floating point (quad-precision) solver? The 128-bit floating point (quad-precision) solver refers to the solver that uses 128-bit (16-byte) floating point arithmetic. It is in contrast to the 64-bit floating point (double-precision) solvers that are the standard for virtually all other structural and finite element analysis programs today. Normally, the 64-bit floating point solver produces satisfactory results for practical uses. However, under some ill-conditioned circumstances, such as when a model is very large or stiffness of elements varies greatly, the 64-bit solver may produce unreliable or even wrong results. The 128-bit floating point solver is extremely accurate and provides an invaluable alternative to the standard 64-bit floating point solver under such ill-conditioned circumstances.
  • Should I always use the 128-bit floating point (quad-precision) solver? No. You normally use the 64-bit floating point solver. However, if significant number of digits is lost during the solving process or when solution becomes unstable, use the 128-bit floating point (quad-precision) solver. It is important to point out that the 128-bit solver uses twice as much memory as the 64-bit floating point solver and is also significantly slower. However, between faster but wrong results and slower but correct results, you as a responsible engineer should choose the latter.
  • Can you give me an simple example where the standard 64-bit floating point solver would fail? Try a simple cantilever beam, fixed at the left end and loaded with a tip force at the right end. Model the beam with 20,000 or more elements. Do not consider shear deformation. The likelihood of wrong results from your familiar structural analysis program is very high. The 128-bit floating point (quad-precision) solver in Real3D will give you the correct results. For details, see Example 1 in the program documentation.
  • Can you give me a practical example where the 128-bit floating point solver (quad-precision) would shine? Consider a floor with much larger in-plane stiffness than out-of-plane stiffness in a 3-dimensional building. Most of the other programs model this kind of rigid diaphragm action through master-slave constraints in order to avoid numerical difficulties. With the 128-bit floating point (quad-precision) solver available in Real3D, you may model the floor as a flexible diaphragm, yielding more realistic results.
  • How reliable is the thick plate (MITC4) bending element? There are literally dozens of plate elements available in different commercial structural or finite element programs. However, very few are both reliable and efficient. The MITC4 plate bending element is arguably the best plate bending element of its kind in the current state-of-the-art. It is shear lock-free and insensitive to distortion of element mesh. See the book "Finite Element Procedures" by K.J.Bathe, Prentice-Hall, Inc, 1996.
  • Can I model a thin plate with the MITC4 plate bending element? Absolutely. Although the MITC4 plate element uses the thick plate formulation, it may be used to model thin plates just as reliably. For a thin plate (t/L < 1/20), the MITC4 and classical Kirchhoff plate elements yield comparable results.
  • Does a thin plate have out-of-plane shear forces? Although the classical thin plate (Kirchhoff) formulation does not account for the out-of-plane shear deformations, out-of-plane shears do exist and are output by the program. To understand this, you may draw an analogy between a plate and a beam. A thin plate is analogous to a Euler-Bernoulli beam while a thick plate is analogous to a Timoshenko beam. We consider shear deformation for the Timoshenko beam but not for the Euler-Bernoulli beam, shear forces exist in both the Euler-Bernoulli and Timoshenko beams.
  • Can I insert another Real3D file into the current model? Yes, you can use the File->Append File command. This feature is very powerful as it allows you to separately build components in a structure and then assemble the components together.
  • Can I open files created in another structural analysis program? No. Real3D does not provide import facilities for files created in other structural analysis programs. However, the program supports importing DXF file import and export. It also offers Autodesk's Revit Structure add-ons.

Real3D - Tips

  • Speed-up graphics Although Real3D uses the most advanced graphics technology, graphics may still take considerable computing time and memory, especially for large models. One useful and practical way to speed up graphics is to minimize the amount of graphics and to display only those that you need to see. For example, annotate only the interested items on selected elements, show loads for selected load cases, freeze uninterested parts of the structure altogether, etc.
  • CPU vs. RAM It is always a good idea to use the latest hardware to perform structural analysis, especially for large models. However, it is usually more economical to have as much RAM as possible than to have the fastest CPU. For example, a computer with a CPU of 500 MHZ and a RAM of 526 MB is more suitable to solve larger models than a computer with a CPU of 2 GHZ and a RAM of 128 MB.   When the solver needs more computer memory than available RAM, solution speed may be significantly slowed down due to the very time-consuming and frequent swapping of data between RAM and hard-disk.
  • What is sCheck? sCheck is a very useful Windows program for structural engineers to design and check steel beam-columns according to ANSI/AISC 360-10.
  • Does sCheck use dongle for copy protection? No. We use software key which is emailed to you after purchase.
  • What types of licenses do you have for sCheck? Perpetual and Subscription-based.
  • Can I install sCheck on both a desktop and a laptop? Yes as long as you do not use the software on both computers at the same time.
  • Does sCheck support Load and Resistance Factor Design (LRFD)? Yes.
  • Does sCheck support Allowable Stress Design (ASD)? No.
  • What are the limitations of the evaluation version of the software? The evaluation version of sCheck 1). can only solve W12 shapes; 2). may not be used for professional purpose.

cColumn - General

  • What is cColumn?cColumn is a powerful Windows program designed specifically for structural engineers to perform Exact axial-flexural analysis and design of concrete sections (beams, columns or walls) according to ACI 318-99 -02, -05, -08, -11, and -14 code.
  • Does cColumn use dongle for copy protection? No. We use software key which is emailed to you after purchase.
  • What types of licenses do you have for cColumn? Perpetual and Subscription-based.
  • Can I install cColumn on both a desktop and a laptop? Yes as long as you do not use the software on both computers at the same time.
  • Why are results not saved when I save a cColumn (verification example) file? cColumn saves the results by default when you save a file. However, you have the option (from the menu Settings | Data Options) to save the input only each time you save the file. This option is used for all verification examples and the tutorial to make the setup footprint small.
  • How can I print interaction diagrams in pdf? cColumn does not support pdf printing directly. However, you can download and install free third party pdf printing software (such as http://www.pdfforge.org/pdfcreator). You can print interaction diagrams from cColumn's File -> Print menu, then select pdf printer such as PDFCreator.
  • How can I save interaction diagrams to jpeg file? You can first print interaction diagrams to a pdf file using the method above. Then you may use tools (such as http://www.zamzar.com/) to convert from pdf file to jpeg file.
  • What are the limitations of the evaluation version of the software? The evaluation version of cColumn 1). can only solve columns with concrete compressive strength of 3.5 ksi; 2). may not be used for professional purpose.

cColumn - Modeling

  • Why does cColumn analyze a uniaxial problem biaxially? cColumn always analyzes a section biaxially due to the uniform approach in its solution algorithm. For a section subjected uniaxial bending, you should input the biaxial angle steps found in the solver option dialog box to be 4. The program will solve for P-Mx(+) and P-Mx(-) capacity in the major axis bending, and for P-My(+) and P-My(-) capacity in the minor axis bending.
  • How accurate is the solution? How fast is the solution? The solution accuracy and speed depend on the solution parameters such as neutral axis steps and biaxial angle steps in the solver options. Generally speaking, more accurate solution requires more solution time. cColumn implements an unique solver that can very accurately solve hundreds even thousands of sections uniaxially or biaxially in seconds.
  • How many neutral axis steps should I set in the solver option? This depends on the problem you are solving. For regular sections, a value of 250 - 500 is generally accurate enough for practical applications. The adequacy of neutral axis steps can be determined by the smoothness of the P-Mx and/or P-My interaction diagram.
  • How many biaxial angle steps should I set in the solver option? This again depends on the problem you are solving. For a regular section, a value of 16 - 32 is generally accurate enough for practical applications. The adequacy of biaxial angle steps can be determined by the smoothness of the Mx - My contour diagram. A low value of biaxial angle steps tends to give more conservative biaxial capacity for the section.
  • Why doesn't the program have a design option? There is no need to provide a design option in the program thanks to its ability to solve multiple sections simultaneously. The design of concrete section embodies at least the following two features: 1). It is a trial-and-error process. 2). More than one solution may be equally plausible. The program recognize this and tries to alleviate the pain of the trial-and-error process while at the same time does not pretend to be too smart to present you with a single final design section. The section generation facility in the program makes it a breeze to parametrically generate (and therefore try) tens, hundreds even thousands of sections with different dimensions and reinforcement layouts. This, combined with the blazingly fast solver, makes it very easy to design a uniaxial or biaxial loaded section. More often than not, you are presented with the opportunity to pick up from among several and equally plausible section candidates. This is the beauty of a good engineering software: It takes off the drudgery of calculation from you but does not deprive you the ability to make sound engineering judgments.
  • How can I adjust the aspect ratio of P-Mx interaction diagram? First, activate the P-Mx interaction diagram view. Then go to menu View | Diagram Type and change the P-M diagram aspect ratio in the dialog box. Also by changing force and moment units, the P-M aspect ratio changes accordingly.
  • Can I annotate the points used in the P-Mx interaction diagram and other result diagrams? The program annotates some key points such as balanced point and pure bending point automatically when you first launch the P-Mx or other result diagrams. To annotate additional points, simply point and click the points with the mouse, or click and drag the mouse to annotate multiple points. To turn the annotations off, press ESC key.
  • Where can I get the result data so that I may construct my own P-Mx interaction diagram in my favorite spreadsheet program? All result data used to construct P-Mx and other result diagrams are transparent to the user from the main menu Result Data. These data are presented in the spreadsheet and are easy to be copied to other spreadsheet program. To copy data from cColumn spreadsheets, just use your familiar keys CTRL+C, CTRL+V.
  • How can I see loads inside the P-Mx_My interaction surface? The P-Mx-My interaction diagram is opaque at this time. However, you have an option to view it as wire-frame so that all loads can be seen. To do that, use menu Settings | Preferences and unselect the option "Show 3D surface (instead of wire frame) for P-Mx-My curve".
  • Does the program accounts for slenderness effects? Yes.
  • What is "SolverBlaze (SDK)"? SolverBlaze Finite Element Library (SDK) is a powerful 32-bit and 64-bit structural and finite element analysis API (Application Programming Interface). It is based on the time-tested finite element solver engine in Real3D, which has been used by hundreds of civil and structural engineering offices in the United States.
  • Why do I need to use SolverBlaze (SDK)? You may use SolverBlaze (SDK) to develop your custom software that needs frame analysis and/or finite element solver. SolverBlaze is not for ordinary end-users.
  • Does SolverBlaze (SDK) offer source code? Yes. You can purchase SolverBlaze (SDK) in either binary or source code form.
  • Can I use SolverBlaze (SDK) in a native C++ environment? Yes. SolverBlaze (SDK) is written in C++ and can therefore be used in C++ programs.
  • Can I use SolverBlaze (SDK) in a .NET environment? Yes. SolverBlaze (SDK) offers .NET programming interface so you can use it with C#, VB.NET languages.
  • Do I need to pay royalty for my custom software? No. SolverBlaze (SDK) is royalty-free. Once you purchase a license fee, you may distribute the redistributables free of charge.
  • Do I need Real3D? No. However, Real3D will help you during the developement with SolverBlaze as it can validate and visualize your model. You can also use Real3D to automatically generate template .NET code, saving you tremendous amount of development time.
  • What are the limitations of the evaluation version of the software? The evaluation version of SolverBlaze (SDK) 1). can only solve model with less than 200 nodes; 2). may not be used for professional purpose.
  • What is OpenGraph? OpenGraph Library (SDK) is a powerful 2D and 3D visualization and charting software tool. It is built on the industrial strength OpenGL. The library shields you from the need to learn the complex OpenGL API and makes it easy to setup impressive and interactive graphics framework quickly. This library is especially suitable for building scientific, engineering and financial software applications.
  • Can I use OpenGraph (SDK) in a native C++ environment? Yes. OpenGraph (SDK) is written in C++ and can therefore be used in C++ programs.
  • Can I use OpenGraph (SDK) in a .NET environment? Yes. OpenGraph (SDK) offers .NET programming interface so you can use it with C#, VB.NET languages.
  • Do I need to pay royalty for my custom software? No. OpenGraph (SDK) is royalty-free. Once you purchase a license fee, you may distribute the redistributables free of charge.